Technical Requirements

What Will I Need To Attend?

For the Internet connection:

Windows

  • Operating System: Windows XP or newer
  • Browser: Internet Explorer 7.0 or above, Mozilla Firefox 3.4 and above, Google Chrome

Mac

  • Hardware: An Intel Based Mac
  • Operating System: Mac OS 10.6 and above
  • Browser: Safari 4 and above, Mozilla Firefox 3.4 and above, Google Chrome

Linux

  • Browser: Mozilla Firefox 3.4 and above, Google Chrome

iOS

  • iOS version 5 or greater

Android

  • Android version 3 or greater

The Adobe Flash plug-in or a HTML5 compatible browser/device

How do I verify Flash is installed?
Verify your installation by visiting the Flash installation page.

What Flash self-help support options are available?
Adobe offers a full Flash support center on their site where you can search, ask questions and get answers to all your needs related to Flash. Visit the Adobe Flash support center.

What if I don't or can't have Flash installed on my system/device?
Peach New Media delivers webinars in both Flash and HTML5, so no Flash plug-in is required with access to an HTML5-compatible browser/device.

Is my browser HTML5 compatible?
Due to the complex nature of HTML5 support, please visit this page to confirm your browser's HTML5 video and audio compatibility. H.264 video and AAC audio must be supported.

Is there any additional relevant information that I can share with my IT department?
This list of server host information may be useful for IT teams getting their attendees set up for the webinar.

For the audio connection using your computer speakers:

A computer with speakers is required or you may dial in using a phone.

To ensure your computer meets the system requirements, please view this test video.